
Twitter
Website Tag
Troubleshooting
Guide

1



Purpose
This document should be used to seek guidance and direction on how to solve issues that arise after
the Twitter Website Tag has been implemented.

Context
Having a healthy set up is important to ensure your campaigns are measuring and attributing results
accurately. Healthy implementation is the foundation that our Web-DR products sit on (eg. Click ID,
Site Visits Optimization, Conversions Optimization). This guide has answers to common questions
asked about the Twitter Website Tag.
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Twitter Website Tag

➔ Page 6
I have just set up my Twitter Website Tag, but I am not sure if it is set up correctly. Are there
steps I can take to confirm the setup is correct?

➔ Page 6
I am not sure if my Twitter Website Tag is Javascript-based. How can I check?

➔ Page 8
The Twitter Website Tag is not including the full scope of my attributed conversions in reporting.

➔ Page 10
I use floodlight tags to track conversions in Google Campaign Manager 360 (CM360) and am
seeing zero or very few conversions being reported in Twitter Ads Manager.

➔ Page 11
How can I check that my website tag is sending the correct tag ID?

➔ Page 13
The Twitter Website Tag is installed in a tag manager system (e.g Google Tag Manager), but the
tag manager system URL firing rules do not match URL firing rules listed in Twitter UI when
setting up conversion events.

Conversion Event Tracking

➔ Page 15
I have set up a conversion event, but I am not seeing any tracking.

➔ Page 16
I have set up multiple conversion events on the same landing page and am noticing
discrepancies in reporting.

➔ Page 19
I want to drive traffic to my website but am not sure how to verify my URL rules are set up
correctly in conversion event tracking.

➔ Page 23
I’m trying to track Site Visit conversions, but my click-to-land or cost-per-site-visit rate is 0.

➔ Page 24
Will using shortened URLs in Tweets impact my ability to track traffic driven to my website?
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➔ Page 24
How can I check that my page’s URLs are being captured correctly?

➔ Page 25
I want to track TOTAL purchase events, or other down-funnel actions like sign-ups.

➔ Page 27
I want to track SEVERAL DISTINCT purchase events, or other down-funnel actions like
sign-ups. E.g. track and report shoe purchases separately from sock purchases.

➔ Page 27
I want to track TOTAL purchase VALUES, but I’m unsure how to modify the Twitter Website Tag
to populate the purchase parameters correctly.

_________________________________________________________________________________________________

Helpful Definitions

➔ Conversion Event: Specifies the type of conversion event being tracked by our tag. This
guidance is referring to Site Visit events in particular. Outcomes you would like to achieve via
advertising, such as page views, sign-ups of various types, or purchases are communicated to
Twitter in the Conversions Tracking Tool within Ads Manager.

➔ Javascript Tag: Twitter’s Javascript-based tags provide richer and typically more accurate
measurement than image-only tags. Both Universal and Single Event Tags can use Javascript.

➔ Image-only Tag: An image-only tag is more static than a Javascript-based tag, and tends to
provide less accurate measurement. Only Single Event tags are available as image-only.

➔ Twitter Website Tag: A tag (snippet of code) an advertiser places across their website in order
to track and measure actions that users take. There are (2) types of tags that can be used, 1)
Universal Website Tag and 2) Single Event Tag

➔ Universal Website Tag: A tag the advertiser places across their site in order to track conversion
events that can be specified by a URL in the Twitter dashboard.

➔ Single Event Tag: A tag an advertiser places on web pages to track non-page load events such
as clicking a download button. The single event tag does not require URL matching rules like
Universal Website Tag.

➔ Events Manager: This is the central hub for advertisers to manage their Twitter Website Tag and
set up web-based conversion events.
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🔍 Identified Issue

I have just set up my Twitter Website Tag, but I am not sure if it is set
up correctly. Are there steps I can take to confirm the setup is correct?

💡 Troubleshooting Tip

Follow the instructions in this video

_________________________________________________________________________________________________

< Back to Directory

🔍 Identified Issue

I am not sure if my Twitter Website Tag is Javascript-based.
How can I check?

💡 Troubleshooting Tip

➔ Any time the tag loads a call for “uwt.js” in the Chrome Network tab, the tag is using Javascript.
This comes from the <script> part of the website tag. We recommend watching this video from
end to end, but 00:46 - 00:52 is where we address this question specifically.

Screenshot of Business Twitter:
A screenshot of the webpage business.twitter.com/en/basics/html. The View > Developer Tools window has been
opened to the Network tab. A search filter for the tag ID “num2q” has been enabled, filtering only calls for that Twitter tag
ID. Two results show up, status 200, for adsct links. Each of these links corresponds to the t.co call and the
analytics.twitter call - both are needed to receive data in your ad account.
Note: If you use a tag manager you can have a full working website tag without the raw tag code appearing within the
webpage source.
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A screenshot of business.twitter.com/en/basics/html. View mode for Developer Tools has been turned on within
the webpage, and the Elements tab is inspected. There is a search filter toggled (Command+F) for the tag ID that
matches the tag ID noted in the Twitter Pixel Helper. The Tag ID has been implemented within the <body> tag of
the webpage and is firing successfully.
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A screenshot of business.twitter.com/en/i.html with the Twitter Pixel Helper toggled open. After clicking into the advanced
debugging information, the URL collected field matches the URL in the navigation bar, meaning the conversions will be
given to the event matching this URL rule.

__________________________________________________________________________________________________

< Back to Directory

🔍 Identified Issue

The Twitter Website Tag is not including the full scope of my
attributed conversions in reporting.

💡 Troubleshooting Tips

➔ Sometimes the HTML code for the Universal or Single Event Tag is placed in the wrong location
in the tag management system.

Scenario #1 [Not using a Tag Manager]

➔ The entire code snippet (Universal or Single Event tag) needs to be visible in the HTML of the
webpage - either directly on the page or integrated through a third party tag manager.
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Here is an illustrative example of where to place the HTML code directly on the page. Note: this may look slightly
different for each website.

◆ If you are using a container tag/tag management system, this is not something Twitter has
visibility into.
Action: Reach out to your third-party partner (e.g. Google Tag Manager) to troubleshoot or
send a screenshot of the container tag setup page to your Twitter Account Manager for
further troubleshooting.
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Scenario #2

➔ Advertisers can place the Twitter Website Tag code in various places on your website.

◆ However, when placing the Twitter Website Tag code near the bottom of the webpage, this
means the website tag code is the last item to load.

◆ If your website page loads slowly, because our tracking code from the website tag doesn’t
load until the entire page loads, this could potentially lead to bounce rates.

➔ Action & Best Practice: By installing the Twitter Website Tag code for the Twitter Website Tag
within the page’s <head> section, this ensures the website tag fires quickly as it would be one
of the first things to load.

◆ Note: Ensure that the tag is not installed within an <iframe>, which will send the wrong
referrer URL and prevent the correct attribution from occurring.

__________________________________________________________________________________________________

< Back to Directory

🔍 Identified Issue

I use floodlight tags to track conversions in Google Campaign
Manager 360 (CM360) and am seeing zero or very few conversions
being reported in Twitter Ads Manager.

💡 Troubleshooting Tips

➔ Floodlight tags are a feature in CM360 that allows for tracking and reporting of conversions.
CM360 is a different attribution ecosystem, but Twitter Website Tags can be piggybacked onto
floodlight tags.

➔ These floodlight tags leverage <iframes>, which often cause the CM360 referrer URLs to be
captured rather than the page URLs that are needed for conversion event attribution.
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➔ Please implement the Twitter Website Tag directly on the page to ensure URLs are passed
correctly in order to trigger attribution correctly.

The following shows how you can see if the Referrer URL is matching the URL you intend to drive to.

__________________________________________________________________________________________________

< Back to Directory

🔍  Identified Issue

How can I check that my website tag is sending the correct tag ID?
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To locate the Twitter Website Tag ID: Go to Ads Manager > Tools > Events Manager

The following image with the elements highlighted in green shows where you can locate the Website Tag ID.

💡 Troubleshooting Tip

➔ This could be caused by a few things:
◆ Tag ID is from a different ads account within your organization
◆ A previous Tag from the correct ads account was implemented, but since deleted in the

dashboard

➔ Please work with your Twitter Account Manager who will file a ticket on your behalf with our
Sales Support team. They will pull this information on the backend to confirm which ads
account the implemented Twitter Website Tag is associated with.
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🔍 Identified Issue

The Twitter Website Tag is installed in a tag manager system (e.g
Google Tag Manager), but the tag manager system URL firing rules do
not match URL firing rules listed in Twitter UI when setting up
conversion events.

💡 Troubleshooting Tips

➔ For Universal Website Tag:

◆ Leverage the network tab referenced in this video (we recommend viewing the entire video)
to see which 'referrerURL' is being sent back in the calls in the network tab, but we
reference this specifically at :56-1:12. If this is different from the URL entered in “URL
contains” or “Exact URL”, please update in the Tag Manager accordingly.

◆ You may also leverage the Twitter Pixel Helper “URL Collected” field under the Advanced
Debug Info to make sure we are capturing the URL specified in the Conversion Event setup:

The below image shows which field to reference within the Twitter Pixel Helper.
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Conversion
Event Tracking
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🔍 Identified Issue

I have set up a conversion event, but I am not seeing any tracking.

💡 Troubleshooting Tips

➔ In Events Manager, you are able to see the tracking status of your conversion event. In this
case, the conversion event could show as “Inactive” or “No Recent Activity”.

➔ This could mean that your website tag is sending information to Twitter and/or the conversion
event may not be mapped to the URL that is firing.

◆ Confirm your URL rules are set up correctly. This is shown in the following section.

◆ Confirm that your Twitter Website Tag is set up correctly. Try using the Twitter Pixel Helper
to verify.

◆ If the issue still persists after refreshing the Events Manager page after 1-2 days, and the
tracking status has not changed from inactive or no recent activity to “active” then submit a
ticket with your Account Manager.
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__________________________________________________________________________________________________

< Back to Directory

🔍 Identified Issue

I have set up multiple conversion events on the same landing
page and am noticing discrepancies in reporting.

Best Practices Note:

➔ If this is an issue, conversion metrics (such as Site Visits) may show zero results.
➔ We recommend having a maximum of one Universal Website Tag per ads account per page.
➔ You may include a Single Event Tag (of any type other than page load/site visit) for any

conversion events that happen on a given page but after page load.

◆ An example of this would be a download button or add-to-cart that does not load a new
URL.

💡 Troubleshooting Tips

➔ If multiple conversion events with the same tag ID are firing on the same page, this may
corrupt our attribution methods.
◆ Ensure there is a maximum of one Universal Website Tag per ads account per landing

page.
◆ You may include Single Event Tags of any type of other page load (e.g Site visit) for

any conversion events that occur on the landing page that does not require an
additional page load that leads to a new URL (e.g download button or add to cart).
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➔ There are a couple options advertisers can take to troubleshoot:

◆ For Universal Website Tag

● After setting up a Universal Website Tag, you will be prompted to create
conversion events.

● If multiple conversion events (e.g. a Site Visit event and a Custom event) are set to
fire on the same landing page) this can lead to duplication in reporting.

The below shows two conversion events (Site Visits and Custom Event) that match the same URL within the
same Universal Website Tag. Review the events in the Events Manager UI to make sure that each conversion
you are tracking is unique from the others.
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● Action:
○ Ensure there are not multiple events firing on the same page by checking that

each page of your website has exactly one copy of the Universal Website Tag
code snippet and that URL logic is unique for each event to prevent errors in
attribution.

◆ For a Single Event Tag

● If a Single Event Tag and a Universal Website Tag are tracking the same
action/conversion event by a user, this may cause errors.

● In general, UWTs are a less-code solution for any conversion that can be tracked via a
page load (e.g landing page visit). SETs are reserved for conversion events that do not
load new pages, but must still be tracked (e.g clicking a Subscribe button).

● Incorrect conversion counting will occur if the UWT and SET are attempting to track the
same event. Therefore, write URL rules for every conversion event that comes with a new
page loading, and generate one SET per conversion event that does not load a new
page.
○ It is safe and correct to re-use an SET across pages if both pages track the same

conversion event. E.g. if “add to cart” buttons appear on five pages, the same SET
code should appear within the button on all five pages.
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● Note: If the Single Event Tag is tracking on-site actions such as a button (e.g Download
button), this should not cause errors in attribution if paired with an existing Conversion
Event (e.g Site Visits). There is a potential for double counting if you are measuring the
same action (e.g two Site Visit conversion events) on the same page land.

● Note: Twitter will not use URL rules for attribution when measuring with a Single Event
Tag.

● Action: Ensure each tag or conversion event implemented is tracking a unique page
and/or action.
○ We recommend having only one conversion event that is being tracked per website

page, but support tracking any number of distinct conversions on a single page.

________________________________________________________________________________________________
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🔍 Identified Issue

I want to drive traffic to my website but am not sure how to verify my
URL rules are set up correctly in Events Manager.

💡 Troubleshooting Tips

When setting up a conversion event, the following URL options are available. We recommend using
the “URL Contains” rule, but this depends on your use case for what you want to track.

1. All website visits: Useful for counting page loads (e.g Site Visits) across the site where
the Universal Website Tag is placed

2. Exact URL: Conversion event only fires if the exact URL is matched (note: this is case
sensitive) and requires the URL’s query string, if any, to also match exactly

3. URL contains: Will capture all conversions if a portion of the URL entered in the event
setup is matched (e.g. “confirmation”). This is recommended over “Exact URL” as it acts
as a dynamic catch-all, and doesn’t rely on exact formatting and URL sequencing that
“Exact URL” does (note: this is case sensitive)

Make sure the three key URLs match. Each of the URLs below need to match in order for us
to accurately track and report on conversions.
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1. URL where campaign is driving

a. When setting up or reviewing your campaign creative, ensure the “website URL” field
contains the landing page URL you want to track.

The green box shows the URL we want to track in this example (e.g baristabar.weebly.com)

b. The above view can be found when creating a website card or video website card by
navigating to Creatives > Cards > Select which card type you want for your ad.

The below screenshots show how to navigate.

20



2. URL included in the conversion event setup. In this example, the conversion event we
select is the Site Visits event that is tracking landings on baristabar.weebly.com URL,
matching the URL we included in the website clicks ad.

a. Navigate to Tools > Events Manager > Add Events
b. Review URL in the “URL contains” or “Exact URL” field (“URL contains” recommended)
c. Ensure this matches the URL from step 1 in the campaign creative setup
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d. The green box is outlining the Conversion Event that is selected as the “Key
Conversion Event” in the campaign optimization preferences for the campaign you are
running

3. URL where the pixel is firing

a. Note: This is information that Twitter does not have full visibility into. You can confirm
which URL is collected as shown in this video (we recommend watching from end to
end). If the incorrect URL is being collected, you may need to explicitly share the URLs
with your Twitter Account Manager for further troubleshooting.
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🔍 Identified Issue

I’m trying to track Site Visit conversions, but my click-to-land or
cost-per-site-visit rate is 0.

💡 Troubleshooting Tip

➔ Review the conversion event type. Unless a Site Visit conversion event is created, the
dashboard will show 0 Site Visits.

➔ Creating other event types (e.g. a Purchase event) is not sufficient to also track a site visit
on the same page. You will need to explicitly set up a Site Visits event to enable the Site
Visits metric in Ads Manager.

➔ There is absolutely no difference in our algorithms between purchases and site visits, and
correctly classifying the event types will never harm your campaign’s performance.
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🔍 Identified Issue

Will using shortened URLs in Tweets impact my ability to track
traffic driven to my website?

💡 Troubleshooting Tip

➔ We do not recommend using third party URL shorteners in your Tweet copy (ex.
bit.ly/12345).

➔ Twitter Click ID is a parameter added to the links clicked on Twitter, which allows us to
track off-platform actions such as site visits.

➔ When shortened URLs are used in Tweets,  the Twitter Click ID parameter can be dropped
by the link expansion service meaning we will not be able to track off-platform actions
resulting from this click.

➔ Twitter’s t.co link expander correctly handles the Twitter click ID and can be used instead
of other services, and will assist in attribution.

________________________________________________________________________________________________
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🔍 Identified Issue

How can I check that my page’s URLs are being captured correctly?

Please check the URL entered in the “Exact URL” or “URL Contains” fields in the Events Manager
page to ensure there is a match between where the event is expected to fire.
Move from “Exact URL” to “URL Contains” and include a portion of the URL that is consistent to
ensure firing each time.

1. Navigate to Tools > Events Manager > Add Events
2. Review the URL entered in the “URL contains” or “Exact URL” field
3. Follow the steps in this video (we recommend watching end to end) to verify the conversion

event is correctly firing on the URL entered
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Note: If the tags are piggybacked on to CM360 Floodlights, Floodlight URLs could be captured
instead of the page URLs where the tags are placed. Implement tags directly on the website
instead.

_________________________________________________________________________________________________
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🔍 Identified Issue

I want to track TOTAL purchase events, or other down-funnel actions
like sign-ups.

Setup tips

➔ You can track down-funnel conversions via the Universal Website Tag (UWT), the Single Event
tag, (SET) or you can mix and match. The UWT is the present and future of conversion
tracking on Twitter, and is recommended for this use case. The SET is only recommended if
your webpage does not have a distinct order-complete page.

➔ Tracking purchases with a Universal Website Tag (UWT)
If set up correctly, the Universal Website Tag code should already be present in the header of
the pages you have set up, and sending page load information to Twitter (when allowed by the
user’s cookie and tracking preferences).

◆ Instructions for Twitter are needed so we can interpret the purchases you want
reported.

● In ads.twitter.com, navigate to Tools > Events Manager > Add Events.
● Name the event (‘All Purchases’ is a good name), and set its type to

Purchase.
● Use the URL Contains field to specify what URL format(s) count as a

Purchase.
● For example, use the rule URL includes “/thank_you” to count every

time a user reaches the thank-you page. Similarly, use the rule URL
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includes “/order_complete” to count every time a user reaches the
/order_complete page.

➔ Tracking purchases with an Single Event Tag (SET)
Tracking purchases with an SET is only recommended for websites that do not have a discrete
“order complete” or “thank-you” page.

◆ Instructions for Twitter are needed so we can interpret the purchases you want
reported.

● If you do not have a SET tracking purchases, visit ads.twitter.com,
navigate to Tools > Events Manager > Add Event Source and select “Use a
single event website tag”.

● Fill in the name (e.g ‘Total Purchases’) and select Purchase as the event
type.

● Coordinate with your engineering team to include the provided HTML and
Javascript code in your website’s code so that Twitter’s code runs
whenever a user has completed a purchase.

💡 Troubleshooting tips

➔ If using a UWT

◆ Use the Twitter Pixel Helper to check that Twitter’s pixel is firing when you load the targeted
thank-you or order complete page, and not being accidentally blocked by cookie
permissions or other page features.

◆ Ensure that the URL rules for your selected Purchase event are error free. For example,
check that the capitalization in Ads Manager matches the capitalization displayed in the
URL bar of your browser when visiting the order complete page.

➔ If using an SET

◆ Use the Twitter Pixel Helper to verify that the installed SET is firing at the expected time in
your conversion flow. Verify that the tag_id appearing in the pixel helper matches the tag_id
of the relevant purchase event in ads.twitter.com
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🔍 Identified Issue

I want to track SEVERAL DISTINCT purchase events, or other
down-funnel actions like sign-ups. E.g. track and report shoe
purchases separately from sock purchases [Troubleshooting tips
coming soon]

_________________________________________________________________________________________________
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🔍 Identified Issue

I want to track TOTAL purchase VALUES, but I’m unsure how to
modify the Twitter Website Tag to populate the purchase
parameters correctly.

💡 Troubleshooting tip

➔ Context

◆ It may be helpful to tackle this problem in two steps.

1. Setting up tracking of total purchases
2. Adding purchase value to existing purchase tracking

➔ Setup Tips

◆ You should already have working tracking of the total number of purchases. If not, use the
contents of this guide.

◆ Tracking purchase value requires partnership with your engineering team, or the use of an
existing tag manager integration. This is because your webpage must be programmed to
send data to Twitter reporting the value of each individual purchase as it occurs.

◆ If you do not have either of the above supports, you will be limited to tracking the total
number of purchases.
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➔ Universal Website Tag Setup

◆ Coordinate with your engineering team, or use an existing tag manager integration to pass
the value of each conversion into the existing Twitter Website Tag.

◆ Your current Twitter Pixel code on this page will contain the following line
twq('track','PageLoad'),

◆ Your engineering team needs to change that line (on the purchase-complete pages(s) only!)
to the following (Note: The following values in green are placeholders. The values in
blue are code comments to help your technical team.)

twq('track','Purchase', {
//required parameters
value: '29.95', (i.e this is the total purchase value as a string)
currency: 'USD', (i.e this is the currency as a string)
num_items: '3', (i.e this would be the number of items in the purchase as a string)

});
◆ Dynamically input the appropriate values for that purchase page, and notice that each

of these values is formatted as a string, and not a raw number.
◆ If using a tag manager, set up the above mapping from your data layer into the field of the

Twitter Website Tag on only the pages tracking completed purchases.
◆ You can check that the setup is working correctly via Twitter’s Pixel Helper. When complete,

you should see the correct value, currency, and number of items appearing in the Pixel
Helper.

➔ Single Event Tag Setup

◆ Coordinate with your engineering team, or use an existing tag manager integration to pass
the value of each conversion into the existing Twitter Website Tag.

◆ Your current Twitter Pixel code on this page will contain the following lines

twttr.conversion.trackPid(alphanumeric tag id here, { tw_sale_amount: 0,
tw_order_quantity: 0);

And the following:

<img height="1" width="1" style="display:none;" alt=""
src="https://analytics.twitter.com/i/adsct?txn_id=alphanumeric tag id
here&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0"
/>
<img height="1" width="1" style="display:none;" alt=""
src="//t.co/i/adsct?txn_id=alphanumeric tag id
here&p_id=Twitter&tw_sale_amount=0&tw_order_quantity=0" />

◆ Partner with your engineering team to change those lines to the following. Changes are
underlined. Use the appropriate values for each page.

● If using a Tag Manager, set up the above mapping from your data layer into the fields of
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the Twitter Website Tag on only the pages tracking completed purchases.
twttr.conversion.trackPid(alphanumeric tag id here, { tw_sale_amount: 29.95, tw_currency:
‘USD’, tw_order_quantity: 3);

<img height="1" width="1" style="display:none;" alt=""
src="https://analytics.twitter.com/i/adsct?txn_id=alphanumeric tag id
here&p_id=Twitter&tw_sale_amount=29.95&tw_currency: USD&tw_order_quantity=3" />
<img height="1" width="1" style="display:none;" alt=""
src="//t.co/i/adsct?txn_id=alphanumeric tag id
here&p_id=Twitter&tw_sale_amount=29.95&tw_currency: USD&tw_order_quantity=3" />

◆ You can check that the setup is working correctly via Twitter’s Pixel Helper. When complete,
you should see the correct value, currency, and number of items appearing in the Pixel
Helper.

💡 Troubleshooting Tips

➔ Check that you are receiving the expected number of purchase conversion events. If not, see
the contents of this guide for purchase event troubleshooting. This page is about adding
conversion value parameters to already-working purchase tracking.

➔ Use the Twitter Pixel Helper to inspect the content of a pixel fire. When stepping through your
purchase flow, you should see the tag fire being captured in the Pixel Helper. Check the
following:

◆ The tag ID matches your UWT tag ID or the appropriate SET tag ID in ads.twitter.com
◆ The purchase amount is accurate
◆ The number of items is accurate
◆ The purchase currency is accurate

➔ If using a UWT, check that there is a Purchase conversion defined (for example, one named “All
Purchases”, and that it is configured to match the URL of the page that loads just after the
purchase is official. Check for typos or capitalization errors.

➔ If using a UWT, ensure that the conversion’s URL rules cover all pages that may appear
immediately post-purchase. You can add multiple “contains” statements to a conversion in
order to capture multiple pages of your webpage within the same conversion.
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Questions?
Contact your Twitter Account Manager.

< Back to Directo
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